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1. MCT Interface 
The MCT User Interface is a Windows application designed to make 
interfacing with MCT products fast and easy.  The User Interface (UI) 
provides a graphical interface to simplify hardware configuration and 
setup.  The MCT UI supports all MCT hardware and currently interfaces 
with following hardware manufactured by LabJack Corporation: 
 
• U12 
• U3LV and U3HV 
• U6 and U6Pro 
• UE9 and UE9 Pro 

 

2. Software Download and Installation 

2.1. LabJack Devices 
Verify the latest LabJack drivers are installed on your computer, 
depending on what LabJack device you will be using.  The U.I. cannot 
communicate with LabJack devices unless the required driver is installed.  
LabJack drivers may be downloaded from the LabJack website.  The 
following table lists supported LabJack devices and required driver.   
 
Table 1.  LabJack devices supported by the MCTU UI and their associated 
driver. 

LabJack Device Driver Name 
U12 ljackuw.dll 

U3LV andU3HV labjackUD.dll 
U6 and U6 Pro labjackUD.dll 

UE9 and UE9 Pro labjackUD.dll 
 
Note: 
The driver required for the device being used is the only driver that must 
be installed on your PC for the U.I. to function properly.  Both LabJack 
drivers do not have to be installed on the host PC. 
 

2.2. Downloading and Installing the MCT UI  
 

• Download the latest version of the MCT UI from the MCT downloads 
page:  

 
www.mocontech.com/downloadsandexamples 
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• Extract the MCT installer from the zip file onto your computer (MCT 
User Interface.msi).  The installer is a Microsoft installer file that will 
copy the MCT User Interface application and supporting drivers onto 
your hard drive. 
 

• Start the MCT Installer by double-clicking on the MCT User 
Interface.msi. 
  

• Follow the prompts on the screen to install the MCT U.I. to the desired 
location on the hard drive.  The default installation path is C:\Program 
Files\Motor Control Technologies.  Alternate drive locations may be 
specified during the installation process. 
 

 
On completion, the MCT User Interface.exe and the MCTUI.dll will be 
located in the Motor Control Technologies folder at the drive location 
specified in the installation process.  Start the MCT U.I. by either 
navigating directly to the executable file in the Motor Control Technologies 
folder, or use the shortcut on the Start Menu. 
 
The MCT U.I. is compatible Windows XP SP3, and Windows 7.  The MCT 
UI requires Windows .Net Framework Version 2.0 or later.  The .Net 
framework may be downloaded from the Microsoft website if a compatible 
version is not already installed your PC. 
 

3. MCT U.I. Operation 

3.1. Starting a New Session 
Use of the MCT UI begins by starting a new session.  Starting a new 
session establishes the MCT device and communication hardware that will 
be used.  MCT hardware and communication may be changed at any time 
by starting a new session. 
 

¾ Select File→New Session from the main menu. 
 
A new window will open prompting the user to start a new session (Figure 
1).  Select the MCT hardware and communication hardware being used 
for this session.  The hardware selected in the Start New Session window 
will be used through the duration of the current session.  MCT or 
communication hardware may be changed at any time by starting a new 
session.  All data collected during a session is deleted when a new 
session is started.   
 

¾ Select the appropriate MCT and communication hardware to use in this 
session. 
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¾ Select the OK button. 
 

 
Figure 1.  New session window. 

 

3.2. Using the MCT U.I. with the DCA-10 

3.2.1. LabJack Configuration 
¾ Select Configure→LabJack Configuration from the main menu. 

 
A new dialog window will open that provides options to establish 
communication between your PC and your LabJack device (Figure 2).  It 
is assumed the user is already familiar with the LabJack connection 
parameters.  Please refer to the appropriate hardware documentation for 
the LabJack hardware being used for further information about LabJack 
functionality. 
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Figure 2.  LabJack hardware configuration window.       
 

¾ Select the LabJack device from the LabJack Device drop-down menu.   
 

¾ Configure USB or Ethernet options as necessary to communicate with 
your LabJack hardware.  
  

¾ Select the Connect button to connect with the LabJack device.  
 
The application will attempt to connect with your LabJack hardware. A 
success message will appear in the message box if a connection was 
successful.  Any errors encountered during the connection process will be 
reported in the message box. 
 

¾ Select the OK button if communication was established between the PC 
and LabJack device. 
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3.2.2. Communication IO Setup 
 

¾ Select Configure→Communication IO Setup from the main menu. 
 
A new window will open for configuring communication lines (Figure 3).  
The current master device and handle are listed at the top of the window.  
Below the Master Device and Device Handle boxes are the Digital IO and 
Analog Inputs group boxes.  Inside the group box are controls to set which 
of the master’s IO lines will connect to the DCA-10’s digital and analog 
lines.  The channels listed in the Digital IO group box are used to send 
control signals to the DCA-10.  The channels listed in the Analog Input 
group box are used to read the analog voltage output from the DCA-10’s 
CS pin. 
  

 
Figure 3.  Communication IO Setup DCA-10. 
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The numbers displayed in the control boxes correspond to an IO channel 
number on the master hardware.  The text to the right of each box lists the 
communication line name and the corresponding channel on the DCA-10 
(listed in parentheses).  Verify the connections made between the DCA-10 
and the master hardware corresponds to what is listed in the Digital IO 
group box.  Valid channel numbers for the master hardware are listed to in 
the bottom-right corner of the IO Configuration group box.  
 
The MCT U.I. provides differential analog inputs for the CS pin.  
Differential readings may be necessary if ground offsets exist between the 
master hardware and the DCA-10 ground.  Select the Differential 
checkbox to enable differential inputs.  Set the negative reference to the 
appropriate analog input.  Connect the negative reference to the DCA-10 
GND pin. 
 
Note: 
Analog inputs on the U12 are not supported by the user interface. 
 

¾ Set the digital IO channels as required. 
 

¾ Set the analog input channels as required. 
 
¾ Select the Configure Hdw button to configure the master hardware.  The 

OK button will activate if the configuration was successful and a success 
message will be displayed.   
 

¾ Select the OK button to close the Communication IO window. 
 

3.2.3. Open-loop Control Window 
¾ Verify power is applied to the DCA-10. 

 
¾ Select Configure→Operating Mode→Open-loop 

 
A new Open-loop control window will open (Figure 4).  All controls are 
disabled except those in the Configure Open-loop group box at the top of 
the window.  In the top-left corner of the Configure Open-loop group box is 
the PWM Frequency control box.  This control sets the PWM frequency 
output from the master hardware.   Valid frequencies are 1kHz to 10kHz. 
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Figure 4.  DCA-10 Open-loop Window 

 
¾ Set the PWM frequency as required. 
 
¾ Press the Configure DCA-10 button. 
 

The Configure Open-loop group box will become disabled and the Open-
loop Controls will activate if the IDCA-10 configures successfully (Figure 
5).  At this point the DCA-10 is ready for open-loop operation.  Controls 
necessary for operation are described in further detail in sections3.2.3.1n 
and 3.2.3.2. 
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Figure 5.  DCA-10 Open-loop operation 

 

3.2.3.1. Bridge Options Group Box  

Enable Bridge 
The Enable Bridge checkbox enables and disables the DCA-10’s H-
bridge.  The H-bridge is enabled when the check box is checked and 
disabled when the checkbox is unchecked.  Disabling the H-bridge with 
the Enable Bridge check box places the H-bridge into a low power sleep 
mode and forces OUT1 and OUT2 into a high impedance state.   

/D1 State 
The /D1 State checkbox controls the state of the disable line on the H-
bridge.  The bridge outputs  (Out1 and Out2) are disabled and placed into 
high impedance state when /D1 State checkbox is checked.  Disabling the 
outputs using the /D1 State checkbox is different than disabling the bridge 
with the Enable Bridge Checkbox.  Disabling the outputs with the /D1 
State check box preserves H-bridge functionality and protection features.  
The /D1 line is useful for allowing a motor to decelerate without braking. 

Motor Direction 
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The Motor Direction check box controls the direction the motor rotates.  
Changing the state of the check box will reverse the motor from the 
current direction of rotation.   
 
Note: 
The actual motor direction (clockwise vs. counter-clockwise) will depend 
on how the motor terminals are connected at OUT1 and OUT2. 

3.2.3.2. Motor Speed 

PWM Duty Cycle 
The PWM Duty Cycle control box defines the duty cycle for the PWM 
motor signal.  The value reported in the control box is updated using the 
slider bar directly below it.  Valid values are 0% (OFF) to 100% (Full 
power). 
 

Update Motor Speed 
Click this button when to update the PWM duty cycle to the value currently 
reported in the PWM Duty Cycle control box.  Motor speed will only 
change when the Update Motor Speed button is pressed. 
 

3.2.4. Data Options 

3.2.4.1. Data Monitoring and Plotting Data 
The Open-loop control window provides options for monitoring certain 
parameters reported from the DCA-10.  When enabled, the data monitor 
will check the listed parameters once every second and report the values 
to the text boxes at the bottom of the window.   Data monitoring is enabled 
when the Enable Monitoring checkbox is checked.   
 
A 128 second history of the motor current data can be displayed on the 
screen.  To enable charting history, set the check in the Chart Current 
checkbox.  (Figure 6).  
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Figure 6.  Open-loop control window with data plotting. 

 

3.2.4.2. Saving Log or Monitor Data 
Motor current data plotted during operation may be saved to file at any 
time.  
 
¾ Configure the DCA-10 for operations. 

 
¾ Select the Enable Monitoring check box 

 
¾ Select the Chart Current check box to start plotting motor current data 

to the screen. 
 

¾ Select File→Save Log Data from the main menu.   
 
A save file dialog box will open prompting the user for a location to save 
the data file.  Select the file destination and press the OK button.  Data 
saved to file is saved as a tab-delimitated text file. 
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3.3. Using the MCT U.I. with the IDCA-10 

3.3.1. LabJack Configuration 
 

¾ Select Configure→LabJack Configuration from the main menu. 
 
A new dialog window will open that provides options to establish 
communication between your PC and your LabJack device (Figure 7).   
 
Note: 
It is assumed the user is already familiar with the LabJack connection 
parameters.  Please refer to the appropriate hardware documentation for 
the LabJack hardware being used for further information about LabJack 
functionality.  

 

 
Figure 7.  LabJack hardware configuration window.       
 

¾ Select the LabJack device from the LabJack Device drop-down menu.   
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¾ Configure USB or Ethernet options as necessary to communicate with 
your LabJack hardware.  
  

¾ Select the Connect button to connect with the LabJack device.  
 
The application will connect with your LabJack hardware when the 
Connect button is pressed.  A success message will appear in the 
message box if a connection was successful.  Any errors encountered 
during the connection process will be reported in the message box. 
 
Note: 
The Tools option is activated in main menu once communication is 
established with the LabJack hardware.  Please see section 3.3.10 for 
more information on options in the Tools menu. 

3.3.2. Communication IO Setup 
¾ Select Configure→Communication IO Setup from the main menu. 

 
A new window will open for configuring communication lines (Figure 8).  
The current master device and handle are listed at the top the window.  
Below the Master Device and Device Handle boxes are two group boxes 
for SPI and I2C/SMBus communications.  One or both group boxes will be 
visible, depending on which methods are supported by the master 
hardware.   
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Figure 8.  Communication IO window. 

 
¾ Select the desired communication method by checking the SPI Active or 

I2C /SMBus Active checkbox.   
 
Inside each group box are a number of controlsto set the communication 
IO channels and clock speed.  Begin by setting the clock factor, which 
determines the clock speed for the serial bus.  
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Table 2 and Table 3 list clock factors and the approximate clock speed for 
SPI and I2C/SMBus communications on LabJack hardware, respectively.   
 
Note: 
10 kHz is the recommended maximum serial clock frequency that should 
be used with the IDCA-10.    
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Table 2.  Clock factors and clock speeds for LabJack SPI serial 
communications. 

LabJack Device SPI Clock Factor SPI Clock Speed (Hz) 
U12 NA 10 kHz (default) 
U3 110 10 kHz 
U6 110 10 kHz 

UE9 20 10 kHz 
 
Table 3.  Clock factors and clock speeds for LabJack I2C/SMBus 
communications. 

LabJack Device SPI Clock Factor SPI Clock Speed (Hz) 
U12 NA NA 
U3 255 10 kHz 
U6 255 10 kHz 

UE9 255 10 kHz 
 
 
The control boxes located below the Clock Factor determine which IO 
lines will be used for serial communications.  The number inside each box 
corresponds to an IO channel number on the master hardware.  To the 
right of each IO control box is text describing the serial bus channel name 
and the corresponding IDCA-10 channel (listed in parentheses). 
  

¾ Set the master’s serial lines to the appropriate IO channels. 
 

¾ Verify the connections between the IDCA-10 and the master corresponds 
to the values set in the previous step.   
 

¾ Select the Configure Bus button to configure the master hardware.  The 
OK button will activate if the configuration was successful and a success 
message will be displayed.    
 

¾ Select the OK button if the serial bus to close the Communications IO 
Window.  
 

3.3.3. Connect with MCT Hardware 
 
Select Configure→Connect with MCT Hardware from the main menu 
 
A new dialog window will open (Figure 9).  At the top of the box is a 
control for setting the device address for the IDCA-10.   
 
Note: 
The device address is only used for I2C/SMBus communications and will 
be disabled when using SPI as the communication method.   
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Figure 9.  Connect MCT Hardware window. 

 
¾ Set the device address to appropriate value between 0 (default) and 127 if 

you are using I2C/SMBus communications.  Ignore the Device ID box if 
using SPI communications. 
 

¾ Select the Connect button. 
. 
The data in the Device Information group box will update when a 
communication connection is established between the master hardware 
and the IDCA-10.  The data will provide hardware/firmware version 
information and the device address stored in the nonvolatile memory.  The 
window will also report the current mode the IDCA-10 is operating in.  
Default/Idle is the default startup state.  Other operating modes can 
appear if the user programmed the IDCA-10 to start up in a particular 
mode.   
 

¾ Review the data and select the OK button to close the window. 
 
Note: 
The device address stored in memory is reported even if SPI is being 
used as the communication method.  This provides a convenient method 
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for determining the device address for I2C/SMBus communications if it is 
not known.  In the event the user does not know the address for I2C 
communication; record the device address using SPI and then reconfigure 
for I2C, using the recorded address. 
 

3.3.4. Configure Operating Mode 
 
The IDCA-10 is capable of operating in four different modes: 
 

1. Open-loop – Open-loop motor control.  Motor speed is defined by the 
PWM duty cycle commanded by the user.  Refer to section 3.3.5 for more 
information. 

2. Speed Control – Closed loop speed control.  A PID controller is used to 
maintain motor speed at a commanded set point.  Feedback for the PID 
controller is derived from a quadrature encoder on the motor.  Refer to 
section 3.3.6 for more information.  

3. Position Control – Closed loop speed and position control.  Motor speed 
and position are controlled using feed back control methods.  The 
feedback signal is derived from a quadrature encoder on the motor.  Refer 
to section 3.3.7 for more information. 

4. Stand-alone – A special mode for any of the three of the operating modes 
described above.  Stand-alone enables control of the IDCA-10 via the 
analog input line AIN instead of the serial bus.  See section 3.3.8 for more 
information. 

 

3.3.5. Open-loop Control Window 
 
Select Configure→Operating Mode→Open-loop from the main menu.  
A new Open-loop control window will open (Figure 10). 
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Figure 10.  Open-loop Control window. 

 
All controls are disabled except those in the Configure Open-loop group 
box when the window first loads.  The IDCA-10 must be configured before 
open-loop functionality is made available.  Controls for configuring open-
loop mode are described in section 3.3.5.1.  

 
¾ Set the configuration controls to appropriate values. 

 
¾ Press the Configure IDCA-10 button to configure the IDCA-10 for open-

loop operation. 
 
The Configure Open-loop group box will disable and the Open-loop 
Controls group box will activate if configuration is successful (Figure 11).  
At this point the IDCA-10 is ready for open-loop operation.  Controls 
necessary for operation are described in further detail in sections 3.3.5.2 
through 3.3.5.4. 
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Figure 11.  Open-loop Controls. 
 

3.3.5.1. Configure Open-loop Control 

IDCA-10 Address 
The IDCA-10 address box reports the IDCA-10 device address.  Change 
the address value to communicate with a different device or leave alone to 
communicate with the current device.  SPI communications does not use 
device addressing for communication.  The IDCA-10 Address box is 
disabled when using SPI communication.   

PWM Frequency (Hz)  
The PWM Frequency control box determines the frequency of the PWM 
signal output to the motor. Valid frequencies are 1kHz to 10kHz. 

Encoder CPR 
The number of counts per revolution for the encoder installed on the 
motor.  The value in Encoder CPR is used for logging and monitoring 
processes.  Incorrect values entered here will result in incorrect motor 
speeds reported by the application. 
 
Note: 
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A motor encoder is not required for open-loop operations.  Set the 
encoder CPR value to a nonzero number if a encoder is not being used. 
 

3.3.5.2. Bridge Options Group Box 

Enable Bridge 
The Enable Bridge checkbox enables and disables the H-bridge on the 
IDCA-10.  The H-bridge is enabled when the check box is checked and 
disabled when the checkbox is unchecked.  Disabling the H-bridge with 
the Enable Bridge check box places the H-bridge into a low power sleep 
mode and forces OUT1 and OUT2 into a high impedance state.   

D1 State 
The D1 State checkbox controls the state of the disable line on the H-
bridge.  The bridge outputs  (Out1 and Out2) are disabled and placed into 
high impedance state when D1 State checkbox is checked.  Disabling the 
outputs using the D1 State checkbox is different than disabling the bridge 
with the Enable Bridge Checkbox.  Disabling the outputs with the D1 State 
check box preserves H-bridge functionality and protection features, and 
allows the motor to decelerate without braking.  

Motor Direction 
The Motor Direction check box controls the direction the motor rotates.  
Changing the state of the check box will reverse the motor from the 
current direction of rotation.   
 
Note: 
The actual motor direction (clockwise vs. counter-clockwise) will depend 
on how the motor terminals are connected at OUT1 and OUT2. 
 

3.3.5.3. Logging Options 

Data Source Dropdown 
Select between one of three sources for logging data on the IDCA-10. 

o Encoder A – Motor encoder channel A. 
o Encoder B – Motor encoder channel B. 
o Motor Current – Current flowing through the motor windings. 

Data Log Period (ms) 
Sets the data logger period, measured in milliseconds.  Data is logged in 
128 sample bursts.  The total time required to collect data is the data log 
period multiplied by 128.  Valid values for the data log period are 5 ms to 
255 ms. 
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Note: 
Data logging can consume a considerable portion of controller resources.  
Multiple consecutive calls to log data can impact controller performance. 

3.3.5.4. Motor Speed 

PWM Duty Cycle 
The PWM Duty Cycle control box defines the duty cycle for the PWM 
motor signal.  The value reported in the control box is updated using the 
slider bar directly below it.  Valid values are 0% (OFF) to 100% (Full 
power). 

Update Motor Speed 
Click this button to update the PWM duty cycle to the value currently 
reported in the PWM Duty Cycle control box.  Motor speed will only 
change when the Update Motor Speed button is pressed. 

Enable Data Logging 
The Enable Data Logging check box enables data logging on the IDCA-10 
when checked.  Data logging parameters are determined by the values set 
in Data Source drop down menu and Data Log Period control box.  Once 
enabled, data logging will begin when the user updates the motor speed 
by selecting the Update Motor Speed button.  The check in the Enable 
Data Logging checkbox will automatically clear when data collection has 
finished.  The UI data logging option is useful for monitoring the step 
response of a motor. 
 

3.3.6. Speed Control Window 
 
¾ Select Configure→Operating Mode→Speed Control from the main 

menu.   
 
A new speed control window will open (Figure 12).  All controls are 
disabled except those in the Configure Speed Control group box.  The 
IDCA-10 must be configured before speed control functionality is made 
available.   Options for configuring speed control mode are described in 
the section 3.3.6.1. 
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Figure 12.  Speed Control Window 

 
¾ Set the IDCA-10 address field to and appropriate value (I2C mode 

only).  The IDCA-10 address field will be disabled when the SPI bus is 
being used for communication. 
 

¾ Set the PWM Frequency field. 
 

¾ Set the PID Period field.   
 

¾ Set the Encoder CPR field.   
 

¾ Press the Configure IDCA-10 button to configure hardware. 
 
Upon successful configuration, the Configure Speed Control group box will 
become disabled, and previously disabled group boxes will become 
enabled (Figure 13).  At this point the IDCA-10 is ready for speed control.  
Controls necessary for operation are described in further detail in sections 
3.3.6.2 through 3.3.6.4. 
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Figure 13.  Speed control window configured. 

 

3.3.6.1. Configure Speed Control Options 

IDCA-10 Address 
The IDCA-10 address box reports the IDCA-10 device address of the 
device connected to in the previous configuration steps.  Change the 
address value to communicate with a different device or leave alone to 
communicate with the current device.  SPI communications does not use 
device addressing for communication.  The IDCA-10 Address box is 
disabled when using SPI communication.   

PWM Frequency (Hz)  
The PWM Frequency control box determines the frequency of the PWM 
signal output to the motor. Valid frequencies are 1kHz to 10kHz. 

PID Period 
The PID Period control box defines the update rate used by the PID 
controller.  This period controls how often the PID controller reads the 
feedback signal to control motor speed.  Valid values are 5 ms to 255 ms. 

Encoder CPR  
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The Encoder CPR control box defines number of counts per revolution for 
the encoder installed on the motor.  The value in Encoder CPR is used by 
the PID controller and is used for logging and monitoring processes.  
Incorrect values entered in the Encoder CPR control box will result in 
incorrect controller operation. 
 

3.3.6.2. Bridge Options Group Box 

Enable Bridge 
The Enable Bridge checkbox enables and disables the IDCA-10’s H-
bridge.  The H-bridge is enabled when the check box is checked and 
disabled when the checkbox is unchecked.  Disabling the H-bridge with 
the Enable Bridge check box essentially turns off the h-bridge and places 
it into a low-current sleep mode.  Protection features available through the 
H-bridge are disabled when it is placed into sleep mode. 

D1 State 
The D1 State checkbox controls the state of the disable line on the H-
bridge.  The bridge outputs  (Out1 and Out2) are disabled and placed into 
high impedance state when D1 State checkbox is checked.  Disabling the 
outputs using the D1 State checkbox is different than disabling the bridge 
with the Enable Bridge Checkbox.  Disabling the outputs with the D1 State 
check box preserves H-bridge functionality and protection features, and 
allows the motor to decelerate without braking.  

Motor Direction 
The Motor Direction check box controls the direction the motor rotates.  
Changing the state of the check box will reverse the motor from the 
current direction of rotation.   
 
Note: 
The actual motor direction (clockwise vs. counter-clockwise) will depend 
on how the motor terminals are connected at OUT1 and OUT2. 

3.3.6.3. Logging Options 

Data Source 
The Data Source dropdown menu is used to select what data to log on the 
IDCA-10. 
• Encoder B – Motor encoder channel B. 
• Motor Current – Current flowing through the bridge and motor. 

Data Log Period (ms) 
The Data Log Period is the period used to log data measured in ms. Data 
is logged in bursts, consisting of 128 samples.  The total time required to 
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collect data is the data log period multiplied by 128.  Valid logging periods 
are 5 ms to 255 ms. 
 
Note: 
Data logging can consume a considerable portion of controller resources.  
Multiple consecutive calls to log data can impact controller performance. 

Enable Data Logging 
The Enable Data Logging check box enables data logging on the IDCA-10 
when checked.  Data logging parameters are determined by the values set 
in Data Source drop down menu and Data Log Period control box.  Once 
enabled, data logging will begin when the user updates the motor speed 
by selecting the Update Motor Speed button (section 3.3.6.4).  The check 
in the Enable Data Logging checkbox will automatically clear when data 
collection has finished.  The UI data logging option is useful for monitoring 
PID controller performance when motor speed is changed. 
 

3.3.6.4. Motor Speed Controls 

PID Gain Constants (Kp, Ki, and Kd) 
The PID gain constant control boxes define the proportional, integral, and 
derivative gain used by the PID controller.  The gain constants can be 
updated at any time by changing the value in the text box and selecting 
the Update PID Constants checkbox. 

Update PID Constants 
The Update PID Constants check box is used to change the PID 
constants.  All three PID constants are updated to the current value in 
each control box when the Update PID Constants checkbox is selected.  A 
check will appear in the checkbox when constants are being updated, and 
will clear when the update process is complete.  PID values are stored in 
RAM and will be erased when the unit is reset.  See section 3.3.10.7 for 
more information on how to save PID constants to nonvolatile memory. 

Update Motor Speed 
The Update Motor Speed button is used to update the speed set point for 
the PID controller.  Motor speed will only change when the Update Motor 
Speed button is pressed.  Data logging will begin when the Update Motor 
Speed button is pressed if the Enable Data Logging check box is checked 
in the Logging Options group box. 
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3.3.7. Position Control Window 
 
¾ Select Configure→Operating Mode→Position Control from the 

main menu.   
 

A new position control window will open (Figure 14).  All controls are 
disabled except those in the Configure Position Control group box.  All 
values in the Configure Position Control box must be set to valid values 
before configuration can continue. 
 

 
Figure 14.  Position control window. 

 
¾ Set the IDCA-10 address field to and appropriate value (I2C mode 

only).  The IDCA-10 address field will be disabled when the SPI bus is 
being used for communication. 
 

¾ Set the PWM Frequency field. 
 

¾ Set the PID Period field.   
 

¾ Set the Encoder CPR field.   
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¾ Press the Configure IDCA-10 button to configure hardware. 
 
Upon successful configuration, the Configure Position Control group box 
will become disabled, and previously disabled group boxes will become 
enabled (Figure 15).  At this point the controller is waiting for commands to 
position the motor.  All positioning is done using the controls in the 
Position Control Options group box.  Further discussion on the use of 
each control is provided in sections 3.3.7.1 through 3.3.7.3. 
 

 
 
Figure 15.  Position control window after successful configuration.  

 

3.3.7.1. Bridge Options 

Enable Bridge 
The Enable Bridge checkbox enables and disables the IDCA-10’s H-
bridge.  The H-bridge is enabled when the check box is checked and 
disabled when the checkbox is unchecked.  Disabling the H-bridge with 
the Enable Bridge check box places the H-bridge into a low-current sleep 
mode and sets the outputs to a high-impedance state.  Protection features 
available through the H-bridge are disabled when it is placed into sleep 
mode. 
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D1 State 
The D1 State checkbox controls the state of the disable line on the H-
bridge.  The bridge outputs  (Out1 and Out2) are disabled and placed into 
high impedance state when D1 State checkbox is checked.  Disabling the 
outputs using the D1 State checkbox is different than disabling the bridge 
with the Enable Bridge Checkbox.  Disabling the outputs with the D1 State 
check box preserves H-bridge functionality and protection features, and 
allows the motor to decelerate without braking.  
 

3.3.7.2. Logging Options 

Data Source 
The Data Source dropdown menu is used to select the data source on the 
IDCA-10. 
• Encoder B – Motor encoder channel B. 
• Motor Current – Current flowing through the bridge and motor. 

Data Log Period (ms) 
The Data Log Period is the period used to log data measured in ms. Data 
is logged in 128 sample bursts.  The total time required to collect data is 
the data log period multiplied by 128.  Valid logging periods are 5 ms to 
255 ms. 
 
Note: 
Data logging can consume a considerable portion of controller resources.  
Multiple consecutive calls to log data can impede controller performance. 

Enable Data Logging 
The Enable Data Logging check box enables data logging on the IDCA-10 
when checked.  Data logging parameters are determined by the values set 
in Data Source drop down menu and Data Log Period control box.  Once 
enabled, data logging will begin when the user updates the motor position 
by selecting the Update Motor Position button.  The check in the Enable 
Data Logging checkbox will automatically clear when data collection has 
finished.  The UI data logging option is useful for monitoring PID controller 
performance when motor position is changed. 

3.3.7.3. Position Controls 

PID Gain Constants (Kp, Ki, and Kd) 
The PID gain constant values define the proportional, integral, and 
derivative gain used by the PID controller.  The values initially reported in 
the control boxes are set to the same values stored in the IDCA-10 RAM.  
The gain constants can be updated at any time by changing the value in 
the text box and selecting the Update PID Constants checkbox. 
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Update PID Constants 
The Update PID Constants check box is used to change the PID 
constants in RAM.  All three PID constants are updated to the current 
value in each control box when the Update PID Constants checkbox is 
selected.  A check will appear in the checkbox when constants are being 
updated, and will clear when the update process is complete.  PID values 
are stored in RAM.  Constants stored in RAM are erased when the unit is 
reset.  See section 3.3.10.7 for more information on how to save PID 
constants to nonvolatile memory. 

Update Motor Position 
The Update Motor Speed button is used to update the speed set point for 
the PID controller.  Motor speed will only change when the Update Motor 
Speed button is pressed.  
 

3.3.8. Stand-alone Control Window 
 
¾ Select Configure→Operating Mode→Stand-alone from the main 

menu.   
 

A new stand-alone control window will open (Figure 16).  All controls are 
disabled except those in the Stand-alone Configuration group box.  All 
values in the Stand-alone Configuration group box must be set to valid 
values before configuration can continue.  Each control in the Stand-alone 
Configuration group box is discussed in detail in sections 3.3.8.1 through 
3.3.8.4. 
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Figure 16.  Stand-alone control window. 

 
¾ Set the IDCA-10 address field to the appropriate value (I2C mode only).  

The IDCA-10 address field will be disabled when the SPI bus is being 
used for communication. 
 

¾ Set the PWM Frequency field. 
 

¾ Set the PID Period field.   
 

¾ Set the Encoder CPR field.   
 

¾ Select a secondary mode from the Secondary Mode drop down menu.   
 

¾ Select a valid analog input range from the AIN Range drop down 
menu.  
 

¾ Set the appropriate values in the PID Configuration group box. 
 

¾ Set the appropriate values in the Stand-alone Constants group box. 
 

¾ Set the appropriate values in the LJ Analog Options group box. 
 

¾ Press the Configure IDCA-10 button to configure hardware. 
 
Upon successful configuration, the Configure Position Control group box 
will become disabled and the other group boxes will become enabled 
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(Figure 17).  At this point the IDCA-10 is ready for stand-alone control 
mode.  Although the AIN line is the only required control input, the MCT 
U.I. provides useful data logging tools for testing in stand-alone mode 
operation.  Section 3.3.8.5 discusses each of these tools in further detail. 
 

 
Figure 17.  Stand-alone control window after successful configuration. 
 

3.3.8.1. Stand-alone Configuration Values 

Device Address 
The device address assigns a unique identifying address to the IDCA-10, 
and is only used with I2C communications.  The device address will be 
disabled when using SPI as the communication method.  Valid device 
addresses are 0-127. 

PWM Frequency 
Sets the switching frequency for the PWM signal output on OUT 1 and 
OUT 2.  Valid PWM frequencies are between 1 kHz and 10 kHz. 

PID Period 
Sets the update rate for the internal PID control loop.  The PID period in 
the control box is represented in milliseconds. 

Encoder CPR 
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Sets the resolution of the motor’s encoder.  The value set in the Encoder 
CPR field is equal to the number of counts reported by the encoder for 
every one revolution of the motor shaft. 

Secondary Mode 
Sets the secondary mode used in for stand-alone mode.  The secondary 
mode may be set to: 

1. Open-loop 
2. Closed loop speed control 
3. Position control 

Analog Input Range 
Sets the analog input range used for controlling the motor in stand-alone 
mode.  The analog input range is scaled to span the operating range 
defined by the values in the Stand-alone Constants group box.   
 

3.3.8.2. PID Configuration  

PID Gain Constants (Kp, Ki, and Kd) 
The PID gain constant control boxes define the proportional, integral, and 
derivative gain used by the PID controller.  The values initially reported in 
the control boxes are set to the same values stored in the IDCA-10 RAM.  
The gain constants can be updated at any time by changing the value in 
the text box and selecting the Update PID Constants checkbox. 
 

3.3.8.3. Stand-alone Constants 
Different values in the Stand-alone Constants group box are available 
depending on the operating mode being used.  Table 4 lists the stand-
alone constants and their applicable operating modes. 
 

Table 4.  Stand-alone constants and applicable operating modes. 

Stand-alone 
Constant 

Open-loop 
control 

Speed 
Control 

Position 
Control 

Dead Band X X X 
Max Duty Cycle X   

Max Speed  X X 
Approach Speed   X 
Dist. Scale Value   X 

Dead Band 
Dead Band sets the dead band for the analog input.  The dead band 
represents the change in analog voltage the IDCA-10 will allow before 
taking action.  For example, setting the dead band to 0.1 volt will set a +/-
0.1 volt range on the last valid analog reading made by at AIN.  The 
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controller will not take action until an analog voltage is read that falls 
outside the dead band range.  This option is useful to deal with noise that 
may be present on the analog control signal.  

Max Duty Cycle  
In open-loop mode the Max Duty Cycle value is used to map a range of 
duty cycles to the analog input range.  The Max Speed value should be 
the maximum permissible duty cycle measured in percent. 

Max Speed 
In speed control mode the Max Speed value is used to map a motor 
speed range to the analog input range.  The Max Speed value should be 
the maximum permissible motor speed represented in RPM. 
 
In position control mode the Max Speed value determines the speed the 
motor starts at when a new position command is sent to the controller. 

Approach Speed 
Sets the target motor speed as the motor reaches its target position.   

Dist. Scale Value 
The distance scale value is used to map the maximum distance the motor 
is allowed to move over the analog input range.  For example, the 
distance scale value for a motor allowed to rotate a maximum distance of 
100,000 counts, using a 0-5VDC analog input range is: 
 

Dist. Scale Value = 100,000 counts ÷  5VDC ÷ 183  = 109.28 →109   
 

Note:  The Dist. Scale Value represents a discrete value.  Round all 
calculated values to the nearest whole number. 
 
The Dist. Scale Value maps motor rotation to the analog input range as 
seen from the motor’s encoder.  Additional scaling may be required to 
account for any gear reduction in the end application. 

3.3.8.4. LJ Analog Options 
 
Note: 
The LJ Analog Options are only available when using the IDCA-10 with 
LabJack data acquisition hardware. 
 

AIN Latch Line Enabled 
Enables the ability to use one of the LabJack’s digital IO lines to control 
the AIN Latch (L.S. 1) on the IDCA-10.  The actual channel used is set 
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after the IDCA-10 is configured for stand-alone mode.  See section 3.3.8.5 
for further details on selecting a digital IO line. 

LJ DAC Enabled 
Enables use of LabJack’s DAC outputs to use for the analog input signal 
to the IDCA-10.   

Analog Output Channel 
Sets the DAC channels to use as an analog output.  Analog Output 
Channel is made available after the LJ DCA Enabled checkbox is 
checked. 
 

3.3.8.5. Stand-alone Tools 
Stand-alone mode is intended for use in applications where a master 
devices is not available for serial data transmissions.  The MCT UI 
provides some useful tools for testing the IDCA-10 in stand-alone 
operations before putting it into service. 

Bridge Options 

Enable Bridge 
Enables or disables the bridge in stand-alone mode.  The bridge is 
enabled when the checkbox is checked (defualt) and disabled when the 
checkbox is unchecked.  The bridge must be disabled in order to save the 
stand-alone configuration to nonvolatile memory (see section 3.3.10.7). 

Motor Direction 
Indicates the current motor direction.  The Motor Direction checkbox is 
only used to report motor direction and cannot be changed by the user. 

Analog Controls 
The options in the Analog Controls group box are enabled if any of the LJ 
analog options were enabled when the IDCA-10 was configured.  

Control Voltage 
Sets the analog output voltage at the LabJack analog output.  Valid values 
are 0V to +5VDC. 

AIN Latch 
Sets the digital IO line that will act as the AIN latch signal. 

Logging Options 
The logging options allow the user to use the internal logger to record 
relevant data at any time.   
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Data Source 
The Data Source dropdown menu is used to select the data source on the 
IDCA-10. 
• Encoder B – Motor encoder channel B. 
• Motor Current – Current flowing through the bridge and motor. 

Data Log Period (ms) 
The Data Log Period is the period used to log data measured in ms. Data 
is logged in 128 sample bursts.  The total time required to collect data is 
the data log period multiplied by 128.  Valid logging periods are 5 ms to 
255 ms. 
 
Start Logging Data 
The Start Logging Data button starts the data logger.  Data logging 
parameters are determined by the values set in Data Source drop down 
menu and Data Log Period control box.  
 
Note: 
Data logging can consume a considerable portion of controller resources.  
Multiple consecutive calls to log data can impede controller performance. 

3.3.9. Data Options 
Each of the three control windows discussed in sections 3.3.5 through 
3.3.8 provide tools for visualizing data retrieved from the IDCA-10.  Data 
plotting tools are located on the right hand side of each control window 
and consist of a plotting area and real-time data monitoring area.  In 
addition, data can be saved to a file for later analysis.  The following 
sections discuss data options. 

3.3.9.1. Plotting Log Data 
Data logged using the IDCA-10’s internal data logger may be plotted to 
the screen for visualization.  Plot log data to the plot panel at the right-
hand side of the window by pressing the Retrieve Log Data button.  The 
data plotted in the window represents all the data stored in the IDCA-10’s 
internal log buffer. 
 
Two radio buttons to the left of the Retrieve Log Data will become active 
when the button is pressed.  These two radio buttons control how the data 
is scaled on the screen.  The Raw Data radio button reports the data in its 
raw form from the IDCA-10’s data buffer.  The Scaled Data button will 
scale the data to relevant engineering units, depending on the data source 
selected by the user.  Figure 18 depicts example data plotted to the UI 
screen. 
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Figure 18.  Data stored in internal log buffer plotted to screen. 

 

3.3.9.2. Data Monitoring and Plotting Data 
Data monitoring is used for real-time monitoring of motor speed, IDCA-10 
temperature, and motor current.  Enable data monitoring by setting the 
check mark in the Enable Monitoring checkbox.  When enabled, the data 
monitor will update the parameter values at the bottom of the window once 
every second.  
 
A 128 second history of the monitor data can be displayed on the screen.  
To enable chart history, set the check in the Chart Data checkbox after 
enabling data monitoring.  Radio buttons will appear next to each 
parameter after charting is enabled.  Select the radio button next to the 
parameter to view its data history.  Figure 19 depicts monitor data 
displayed on the screen. 
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Figure 19.  Motor speed history plotted to the screen.  

 

3.3.9.3. Saving Log or Monitor Data 
Controller data plotted during operation may be saved to file at any time.   
 
¾ Configure the IDCA-10 for a particular operating mode. 

 
¾ Plot log data or monitor data to the plot area. 

 
¾ Select File→Save Log Data from the main menu.   
 
A save file dialog box will open prompting the user for a location to save 
the data file.  Select the file destination and press the OK button.  Data 
saved to file is saved as a tab-delimitated text file. 
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3.3.10. MCT U.I. Tools Menu 

3.3.10.1. Firmware Update  
¾ Select Tools→Firmware Update from the main menu.   

 
The Firmware Update Utility will open on the screen (Figure 20).  At the 
top of the dialog window is hardware information that reports master 
device, MCT device, and communication information. 
 

 
Figure 20.  Firmware update tool. 
 

¾ Select the Browse button in the File Information group box to locate the 
firmware source file. 
 
Note: 
MCT firmware files are denoted by the .fmw file extension. 
 

February, 2011 Rev 1.2 Page 41 of 52 



¾ Select the Upload Firmware button to start the update process.  A 
confirmation dialog window will appear asking the user if they want to start 
the update process. 
 

¾ Select the OK button in the confirmation window to start the update 
process. 
 
The MCT UI will start the update process by resetting the MCT hardware.  
A series of flashes from the red and green LEDs indicates the update 
activity is in progress.  The firmware update window will post various 
update messages and a progress bar at the bottom of the dialog box. 
 
Note: 
THE MCT hardware will remain in boot mode if the update process is 
terminated due to power interruption or other error.  In such an event, 
cycle power on the MCT hardware.  The green LED will flash four times 
followed by four flashes from the red LED, indicating it is still in firmware 
update mode.  Repeat the firmware update process, starting at the first 
step in this section. 
 

¾ Select the OK button when the FLASH update is complete. 
 

3.3.10.2. Calibration Constants 
The Update Constants Tool accesses the calibration constants for 
temperature, current feedback and analog input.  These parameters are 
calibrated at the factory, but may be adjusted if necessary. 

 
¾ Select Tools→Calibration Constants from the main menu. 

 
The Update Constants tool will open on the screen (Figure 21).  At the top 
of the screen are three group boxes corresponding to three sets of 
calibration parameters.  The values stored in RAM will populate each of 
the control boxes when the window opens.  The group box located below 
the Temperature and Current Feedback group boxes contains the controls 
for updating each constant.  Each radio button in the group box controls 
which parameter set is active for updating.  The Update Constants button 
writes the value from the active parameter group box to RAM. 
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Figure 21.  Update calibration constant tool. 

 
¾ Activate one of the calibration constant set by selecting the appropriate 

radio button (Temperature, Current Feedback, or Analog Input). 
 

¾ Update the slope and offset values as required. 
 

¾ Press the Update Constants button to write the calibration constants to 
RAM. 
 

¾ Repeat update procedure for other parameter sets if necessary 
 
The calibration constants will be used by firmware immediately after they 
are written to RAM.  Although the updated constants are in memory, they 
will be lost if the device is reset.  The calibration constants must be saved 
to nonvolatile memory to make changes permanent. 
 

¾ Select the Save Constants button located in the group box below the 
Analog Input group box. 
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The UI will command the device to save the constants to nonvolatile 
memory.  The save operation will not take place if the IDCA-10 is currently 
controlling a motor.  In such an event, the UI will post a warning message 
instructing the user to place the controller into a safe state before data is 
written to memory.   
 
The controller will automatically reset after the calibration parameters are 
saved to nonvolatile memory.  The MCT hardware will return to Idle mode 
after reset unless it is programmed to power up in a specific mode.  Some 
degree of reconfiguration will be necessary after the reset is performed. 

 
¾ Select the Exit button. 

 
¾ Select Tools→Calibration Constants from the main menu. 

 
¾ Verify the updated calibration constants appear in the their respective 

control boxes when the Update Constants Tool opens. 
 

¾ Select the Exit button to return to normal operation. 
 
Note:   
Factory calibration constants are permanently deleted when constants are 
written to nonvolatile memory.  The user should record factory values for 
future reference before any changes are made. 
 

3.3.10.3. Reset Slave Device 
Select Tools→Reset Slave Device from the main menu. 
 
The Reset Slave Device Utility window will appear on the screen (Figure 
22). 
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Figure 22.  Reset slave device utility window. 

 
The Reset Slave Utility will force the IDCA-10 to reset.  Three different 
resets are available in the reset utility and are described below. 

Software Reset  
Software Reset forces the MCT device to reset much the same as cycling 
power.  The MCT device will reset and go though normal power-up 
initialization.  Data stored in RAM will be lost when the IDCA-10 resets. 

Force to Idle State 
Performing a software reset with the Force to Idle State radio button 
selected forces the IDCA-10 to reset into idle mode, regardless of what 
state it is programmed to start in.  This option is useful for reconfiguring 
the IDCA-10 when it is programmed to power up in a specific mode. 

Restore Default Settings 
The Restore Default Settings button forces a software reset, and causes 
the IDCA-10 to revert to its default factory settings.  Nonvolatile memory 
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contents e are erased after this option is invoked.  Calibration constants 
are not affected by option. 

3.3.10.4. Set Slave Address 
 

¾ Select Tools→Set Slave Address from the main menu. 
 
The Slave Address Tool window will appear in the window (Figure 23).  
The current slave address is displayed in the box at the top of the window.  
Change the device address by entering a new device address in the New 
Address control box.   
 

 
Figure 23.  Update slave address box. 

 
¾ Enter slave address in the New Address control box. 

 
¾ Press the Set Address button to update the device address. 

 
¾ Select the OK button to exit. 
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Note: 
The slave address is set with the Slave Address Tool will be erased when 
if the device is reset.  The address will only be stored in nonvolatile 
memory and made available at boot if the current configuration is saved.  
See section 3.3.10.7 for more information on saving data to nonvolatile 
memory. 

3.3.10.5. Read Error Queue 
 
The Read Error Queue tool reads the current error/warning value stored in 
the internal error register. 
 

¾ Select Tools→ Error Queue from the main menu. 
 
A new window will appear on the screen (Figure 24).   
 

 
Figure 24.  Check Error Queue window. 

 
¾ Press the Read Error Queue button to read the current error code.  The 

error code will be displayed in the message box.  Set the Clear Error 
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button before pushing the Read Error Queue to reset the error code in 
RAM after reading. 
 

¾ Press the OK button to close the window. 
 

3.3.10.6. Clear Instruction Buffer 
 
The Clear Instruction Buffer tool allows the user to clear pending 
instructions in the instruction buffer. 
 

¾ Select Tools→Instruction Buffer→Clear Buffer from the main menu. 
 
A dialog box will appear on the screen informing the user that buffer 
contents will be erased (Figure 25). 
 

 
Figure 25.  Clear instruction buffer dialog box.   
 

¾ Select Yes to continue and erase pending instructions.  Select No to quit 
without erasing instruction buffer. 
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3.3.10.7. Save Slave Configuration 
 

Select Tools→Save Hardware Config from the main menu. 
 

A dialog box will appear on the screen warning the user that they are 
about to set the current configuration as the default hardware 
configuration at power up.   
 

¾ Select the OK button to save the current configuration to nonvolatile 
memory.  The IDCA-10 will automatically reset when configuration values 
are saved to memory. 
 
Note: 
The IDCA-10 will not allow the user to save data to nonvolatile memory if 
the bridge is enabled.  Always stop the motor and disable the bridge 
before saving data to nonvolatile memory. 

3.3.11. Serial Data View 
 
The MCT UI provides a useful tool for inspecting data packets passed 
between the IDCA-10 and communication hardware.  This option is made 
available on the main menu after the IDCA-10 is configured for an 
operating mode.  
 

¾ Select View→Serial Data from the main menu. 
 
The Serial Data window will open next the current operations window in 
the UI (Figure 26).  The Serial Data window has two data boxes that 
display the data packets as they are transmitted between the master 
hardware and the IDCA-10.  Data in the display boxes is updated any time 
a new command is sent to the IDCA10 from the UI. 
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Figure 26.  Serial data view window. 

 

3.3.12. Limit Switch Configuration Window 
The Limit Switch Configuration window configures the two limit switch 
inputs on the IDCA-10 (LS1 and LS2).  Limit switch configuration is 
enabled after the IDCA-10 is configured for Open-loop, Speed Control, or 
Position control modes. 
 

¾ Configure the IDCA-10 for one of its operating modes. 
 

¾ Select Limit Switch→Configure from the main menu to open the Limit 
Switch Configuration Window. 
 
A new window will open on the screen with options for configuring the two 
limit switches (Figure 27).    Each limit switch has three control options 
described below. 

Enable L.S. 
The Enable L.S. 1 and Enable L.S. 2 check boxes enable and disable limit 
switch operation.  Both limit switches are disabled by default.  Set the 
check in the enable checkbox to enable a limit switch input.  One or both 
of the limit switch inputs can be enabled at any time. 
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Deceleration Factor 
The declaration Factor determines the rate the motor decelerates when 
the limit switch input is activated.  The IDCA-10 will decrease the 
command speed according the Declaration Factor once every 50 ms until 
the motor comes to a stop.  Valid values for the deceleration factor are 1-
255. 

AIN Latch (Standalone mode only) 
An AIN Latch option will appear below Enable LS 1 when operating in 
stand-alone mode.  AIN Latch is used to inform the IDCA-10 that the 
analog voltage at AIN is valid and an action should be taken.  The IDCA-
10 will not read the analog input voltage unless the LS1 line is logic LOW 
when the AIN Latch box is selected. 

 

 
Figure 27.  Limit switch configuration screen. 
 

¾ Enable/Disable limit switch inputs as necessary 
 

¾ Enable/Disable AIN Latch if operating in stand-alone mode. 
 

¾ Update the Deceleration Factor control box for enabled limit switch inputs. 
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¾ Press the Configure Limit Switches button to configure the inputs on the 
IDCA-10. 

 
¾ Press the OK button to exit the Limit Switch Configuration Window. 
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